Flutter 2.8.1 & Dart 2.15.1 update on stable channel

Dart:

  • dart/47914 – AOT compilation fails with error “Invalid argument(s): Missing canonical name for Reference”
  • dart/47815 – Running dart pub publish with custom pub package server that has URL containing a path may fail.

Flutter:

  • flutter/94914 – Apps using google_sign_in or google_maps don’t build in iOS Simulator on ARM macOS
  • flutter/90783 – In rare circumstances, engine may crash during app termination on iOS and macOS

In order to get the latest, run ‘flutter upgrade’

Leave a Reply